Back to overview
Telstra MNP Unplanned Delay
Jun 25 at 01:00pm AEST
Resolved
Jun 25 at 01:00pm AEST
Delays to processing of some Telstra MNP port messages impacting both port in and port out
Outage Status : RESOLVED
Date & Time of Outage: 25/06/2022 1:00 PM AEST
Issue Restore Time: 25/06/2022 8:40 PM AEST
Affected services