Back to overview
Resolved

Major network outage

Jul 7, 2026 at 9:51pm UTC
Affected services
Service: Voice
Service: Data
Service: SMS & MMS
New Service Activations
My ALDI Mobile Login
My ALDI Mobile Dashboard & Recharges
Mobile App

Resolved
Jul 10, 2026 at 1:02am UTC

This will be our final update regarding this issue.

The network outage impacting services was resolved on 09/07/2026 at 12:30pm AET.

Telstra Wholesale has advised that they have implemented a solution to address the impact of the secondary Triple Zero calling error and that customers can feel confident calling Triple Zero.

Telstra Wholesale also advised that some customers may have experienced brief delays in call connections on the afternoon of 09/07/2026. This was related to a minor traffic congestion issue, which has since been resolved. Technology teams will continue to monitor the network closely.

All ALDI Mobile orders and provisioning activities, including Auto Recharge, are processing as normal and both My ALDI Mobile and the app are working as expected.

If you have any questions or concerns, please contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue resolved, order backlog resolved, secondary 000 issue resolved, brief call connection delay issue resolved and being monitored
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Issue is now resolved
  • Geographic areas impacted: Nationwide 
  • Impacted services: 100,000+
  • Types of services impacted: Currently none
  • Types of functions impacted: Currently none
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: Final update - all issues resolved

Updated
Jul 9, 2026 at 9:43am UTC

The network outage impacting services is now resolved.

All orders and provisioning activities, including Auto Recharge, are processing as normal and both My ALDI Mobile and the app are working as expected.

Telstra Wholesale has advised that they have implemented a solution to address the impact of the secondary Triple Zero calling error and that customers can feel confident calling Triple Zero.

Telstra Wholesale also advised that some customers may have experienced brief delays in call connections this afternoon. This was related to a minor traffic congestion issue, which has since been resolved. Technology teams will continue to monitor the network closely.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue resolved, order backlog resolved, secondary 000 issue resolved, brief call connection delay issue resolved and being monitored
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide 
  • Impacted services: 100,000+
  • Types of services impacted: Currently none
  • Types of functions impacted: Currently none
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 10/07/2026 @ 07:43pm AET

Updated
Jul 9, 2026 at 3:59am UTC

The network outage impacting services is now resolved, with all orders and provisioning activity - including Auto Recharge have been processed and restored.

My ALDI Mobile and the app are working as expected.

Telstra Wholesale has advised that overnight, good progress was made reducing the occurrence of the secondary Triple Zero calling error by approximately 90%, with work continuing to eliminate the issue entirely. Welfare checks remain in place for any failed Triple Zero calls detected.

If you experience any issues calling Triple Zero, please immediately retry your call. This has reportedly resolved the issue in the majority of cases.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue and order backlog resolved, secondary 000 issue ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide 
  • Impacted services: 100,000+
  • Types of services impacted: Emergency services
  • Types of functions impacted: Some voice calls to 000
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 10/07/2026 @ 08:27am AET

Updated
Jul 8, 2026 at 10:27pm UTC

The majority of pending orders have now been processed, and our teams will continue working through any from yesterday that were delayed due to the outage.

Auto Recharge processed as normal. My ALDI Mobile and the app are also now working as expected.

Telstra Wholesale has advised that overnight, good progress was made reducing the occurrence of the secondary Triple Zero calling error by approximately 90%, with work continuing to eliminate the issue entirely. Welfare checks remain in place for any failed Triple Zero calls detected.

If you experience any issues calling Triple Zero, we recommend you wait for your phone to connect to an alternative network if one is available, this can take up to 90 seconds, or use a different phone to make the call.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue and order backlog resolved, secondary 000 issue ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: Emergency services
  • Types of functions impacted: Some voice calls to 000
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 10/07/2026 @ 08:27am AET

Updated
Jul 8, 2026 at 3:39pm UTC

The majority of pending orders have now been processed, aside for some held up by pre-port verification and other downstream issues. Our teams will continue working through these during business hours.

Auto Recharge commenced on time, and is processing as normal. My ALDI Mobile and the app, including login and all native features, are also now working as expected, so you may place new recharge and other requests again without issue.

The secondary Triple Zero issue continues, we have no new information from Telstra Wholesale at this time. To recap, some calls may receive an error message while devices try to connect to an alternative network. If affected, the advice is to wait up to 90 seconds for reconnection, or use a different phone to call. Telstra Wholesale will be performing welfare checks where failed 000 calls are detected.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue and order backlog resolved, secondary 000 issue ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: Emergency services
  • Types of functions impacted: Some voice calls to 000
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 09/07/2026 @ 07:39am AET

Updated
Jul 8, 2026 at 12:59pm UTC

The issue impacting mobile calls, SMS and data has now been resolved. Recharge, activation and SIM swap orders placed during the outage have now started processing, and may see a short delay. Auto Recharge may run a little later than usual, but allowances are maintained if credit is available.

Telstra Wholesale has also advised of a secondary issue affecting some calls, including Triple Zero. You may receive an error message while your phone tries to connect to an alternative network. If affected, wait up to 90 seconds for reconnection, or use a different phone to call. We're working urgently with Telstra Wholesale to resolve this and they'll be performing welfare checks where failed 000 calls are detected.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Original network issue resolved, new 000 and backlog processing ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: Provisioning, Some emergency services calls
  • Types of functions impacted: Some voice calls, order backlog processing
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 09/07/2026 @ 04:59am AET

Updated
Jul 8, 2026 at 11:31am UTC

Our network provider has advised that the issue impacting the majority of mobile services is now resolved, though it still may take some time for all devices to reconnect correctly.

Provisioning events such as manual recharges, activations and SIM swaps are still impacted, with orders remaining queued. However if before today, your service was set for Auto Recharge to be scheduled tonight, then this will still apply automatically to your plan from midnight, there's nothing you need to do.

Access and functionality of My ALDI Mobile and the app continue to be affected as we wait for full platform connectivity to be restored. You may be able to login, but will be unable to perform any updates for the meantime.

For further updates, please continue monitoring this page, or contact us on 1300 989 000, 8am - 9pm AET.

Event details

  • Outage scale: Major Outage
  • Outage status: Ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: 4G Mobile, 5G Mobile, Provisioning, Selfcare, Mobile App
  • Types of functions impacted: Voice calls, mobile data, SMS, recharges, activations, SIM swaps, login
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 09/07/2026 @ 03:31am AET

Updated
Jul 8, 2026 at 5:31am UTC

Our network operator has made progress restoring mobile services, with most calls and data now working and continuing to improve as the network stabilises. Some customers may still experience intermittent voice issues while devices reconnect. If you're impacted, we recommend restarting your phone, as this is helping restore service in most cases.

Provisioning events such as recharges, activations and SIM swaps remain impacted, with orders remaining queued. Access and functionality of My ALDI Mobile and the app is also impacted as we wait for full platform connectivity to be restored.

For real-time updates, please continue monitoring this page or contact us on 1300 989 000.

Event details

  • Outage scale: Major Outage
  • Outage status: Ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: 4G Mobile, 5G Mobile, Provisioning, Selfcare, Mobile App
  • Types of functions impacted: Voice calls, mobile data, SMS, recharges, activations, SIM swaps, balance enquiries, login
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 08/07/2026 @ 09:31pm AET

Updated
Jul 8, 2026 at 3:09am UTC

Mobile data, voice calls and SMS continue to recover. If you are still experiencing issues, we recommend restarting your phone rather than just switching on airplane mode.

Provisioning events such as recharges, activations and SIM swaps remain impacted, along with login to My ALDI Mobile and the app.

For real-time updates, please continue monitoring this page or contact us on 1300 989 000.

Event details

  • Outage scale: Major Outage
  • Outage status: Ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: 4G Mobile, 5G Mobile, Provisioning, Selfcare, Mobile App
  • Types of functions impacted: Voice calls, mobile data, SMS, recharges, activations, SIM swaps, login
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 08/07/2026 @ 07:09pm AET

Updated
Jul 8, 2026 at 2:13am UTC

Mobile data, voice calls and SMS are recovering, however recharges, activations and SIM swaps remain impacted, along with login to My ALDI Mobile and the app.

For real-time updates, please continue monitoring this page or contact us on 1300 989 000.

Event details

  • Outage scale: Major Outage
  • Outage status: Ongoing
  • Outage cause: Network timing systems
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: 4G Mobile, 5G Mobile, Provisioning, Selfcare, Mobile App
  • Types of functions impacted: Voice calls, mobile data, SMS, recharges, activations, SIM swaps, login
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 08/07/2026 @ 06:13pm AET

Updated
Jul 8, 2026 at 12:29am UTC

Around 90 percent of calls and data are now flowing successfully across the network and our network operator is working as quickly as possible to restore the remaining impacted services.

We'll share further updates until all is resolved and we apologise for the inconvenience.

Updated
Jul 7, 2026 at 10:59pm UTC

Some services have been able to re-connect to the mobile network by switching their device to Airplane Mode and then switching Airplane Mode off.

Created
Jul 7, 2026 at 9:51pm UTC

Major network outage

Description

  • There is a major network outage affecting some customers nationwide
  • An initial network issue was identified at 05:53am AET, 08/07/2026
  • Our network operator then advised us of a major outage at 08:18am AET, 08/07/2026
  • Our Response Team is working to identify the cause
  • We apologise for any inconvenience caused

For real-time updates, please continue monitoring this page or contact us on 1300 989 000.

Event details

  • Outage scale: Major Outage
  • Outage status: Investigating
  • Outage cause: Under investigation
  • Estimated resolution timeframe: Unknown
  • Geographic areas impacted: Nationwide
  • Impacted services: 100,000+
  • Types of services impacted: 4G Mobile, 5G Mobile
  • Types of functions impacted: Voice calls, mobile data, SMS
  • Date & time issue began : 08/07/2026 @ 05:53am AET
  • Next update available by: 08/07/2026 @ 10:56am AET