Back to overview
Degraded
Significant Local Outage - Mission River, QLD, 4874
Jul 09 at 08:11am AEST
Affected services
Service: Voice
Service: Data
Service: SMS & MMS
Resolved
Jul 09 at 12:43pm AEST
Restored on 09/07/2025 at 12:41 AEST.
Affected services
Service: Voice
Service: Data
Service: SMS & MMS
Created
Jul 09 at 08:11am AEST
Geographic Area: MISSION RIVER, QLD, 4874
Remoteness: Very Remote Australia
Technology Impacted: Mobile
Cause: Under Investigation
Potential Impact: 2256 services*
Estimated Next Update: To be determined
Estimated Time of Restoration: To be determined
*Note: The estimated number of impacted services listed below includes services across the entire Telstra and Telstra Wholesale mobile networks.
Affected services
Service: Voice
Service: Data
Service: SMS & MMS