Back to overview
Degraded

Significant Local Outage - Hail Creek, QLD, 4742

Jul 07 at 08:25am AEST
Affected services
Service: Voice
Service: Data
Service: SMS & MMS

Resolved
Jul 08 at 08:15am AEST

Restored on 07/07/2025 at 20:51 AEST.

Created
Jul 07 at 08:25am AEST

Geographic Area: HAIL CREEK, QLD, 4742
Remoteness: Remote Australia
Technology Impacted: Mobile
Cause: Under Investigation
Potential Impact: 1126 services*
Estimated Next Update: To be determined
Estimated Time of Restoration: To be determined

*Note: The estimated number of impacted services listed below includes services across the entire Telstra and Telstra Wholesale mobile networks.